1/10 Second Power Outage = Sense Offline


#101

So, to keep this response alive, thanks for your acknowledgement of what I’ve stated!
And also, no resolution.
To be clear, I only posted what I did as a utter dismay at the response I received from support.
At some point we could only hope that there’d be some actionable response to what I I posted.
This is clearly really a bad design flaw, nothing less. Since this is an imperfect world, I would hope we could get confirmation of that.
Regards
-TD


#102

Roughly translated, my Roku runs with 99.9% uptime over wireless.
This product runs less then 50%, It sits less than 15 ft away from Roku device!. And fails from all scenarios… , Hint design problem ?? Hint Hint, logging baby sweet!
For the Noob, I can’t work … please tell me why!
Furthermore , 50% is not fair, this is is a situation where NO CLUE why …,I.e change this, tried that, which I don’t think any of this is occurring, Hence the problem… Seriously no logging at all, Just i’m not working now?
It’s called experience = Grade D-
In this day and age I can’t believe we have to ask for the ability to have a log for you to discern what the problem is. Cause there is none??


#103

From a WiFi and Bluetooth communications perspective, the Sense is basically one of these:
http://www.ti.com/tool/TIEP-SMART-ENERGY-GATEWAY
Uses the same host processor (TI Sitara AM3352) and TI WiFi / Bluetooth module (WL18MOD). Roku pretty much uses Broadcom chips.

With the amount of sampling and processing the host is doing (even with the help of the CPLD), I’m betting that there isn’t very much headroom for ancillary functions like logging.


#104

Great info.
I’m not sure but from the behaviour I see, I doubt logging would even help. I just had to power cycle mine again.
What I think is happening has to do with very brief power outages, fraction of a second. Instead of completely shutting down like most devices, it goes into a half dead state that it can’t recover from.
I see I should’ve replied on this thread (1/10 Second Power Outage = Sense Offline)


#105

Have you worked with Support on this at all?

I’m going to go ahead and merge this with the existing thread.


#106

One more interesting tidbit - it would appear that that Sitara platform family might be prone to lockup when encountering short power glitches…
https://e2e.ti.com/support/processors/f/791/t/495303


#107

Yes I did, support id 101316
And sorry, I realized the other more extensive thread after the fact.


#108

I spoke to Support and this is being brought to our lead EE to try and figure out what’s going on. I’ll let the Support agent update you personally but I’ll also update the thread when I know more.

Thanks, Ryan. I am happy to help your EE with any additional data collection or troubleshooting that is necessary here. I have a networked UPS that logs AC power data (although probably not with the resolution required for this purpose) and various insights into my home network happenings, so feel free to send requests my way. I am out of the country for the next few weeks, but can get access to most of that data remotely.


#109

Kevin, perfect, And exactly what I was referring to!
Without a hardware change , is there a way to program around that behaviour I wonder? :slight_smile:

So I’m curious, this is a seriously long running thread. There has been no fix to date?

From a lab perspective, how hard would it be to simulate and uh fix or at least confirm this problem? By confirm I mean specifically its a) a board problem and can’t be fixed or B) it’s board problem and can be worked around eventually, i.e we’re working on the fix.
Or has then been established already and I missed it?


#110

^ I posted this back in June. Our engineers are still looking into @pswired’s issue, but it seems like something else may be going on. A hardware replacement is still the solution for the problem, and Support can diagnose to make sure you’re experiencing this exact issue.


#111

So there is an actual hardware fix?In general, If I were start over with a new device, would it learn faster based on previous discovery?


#112

If your issue is caused by voltage dips/brownouts, yes, new hardware should solve the problem, but Support will have to diagnose to make sure that is the exact issue you’re dealing with.

At this moment, previous discovery would have no bearing on a new device. There is no method of data transfer between the two. This is a very complicated problem to solve, but something we’re hoping to add in the future.


#113

Bummer, OK sounds good, thanks


#114

Thanks for this, Kevin. I showed it to the EEs and they don’t think it’s the culprit, but will investigate further.

Per @pswired’s issue: We did some digging and it does not appear to be a hardware issue. The monitor replacement should still have successfully solved the brownout shutdown issue. This appears to be Wi-Fi related and a fix is being tested. I’ll post more when I have it.


#115

@RyanAtSense,
Thanks - I was just speculating. But I have yet to find a complex hardware system that can survive power drops / brownouts without the potential of a lockup. There’s just too much weirdness and unpredictability that goes on when you drop well below the operating voltage of a bunch of components all tied together. Generally the HW solution is to improve the power supply (bigger caps), or a reboot mechanism after brownout.


#116

Would a more robust grid be too much to ask for this Christmas? :christmas_tree:

I count myself lucky to live in a place where brownouts are incredibly rare.


#117

Hold a raffle for a Tesla power wall? :battery: :smiley:


#118

Had this happen last night again

I think the issue is that when you lose power your Wifi make take up to 5 min to come back (e.g. Cable modem/DSL reset, etc). Why doesn’t Sense attempt to reconnect to WiFi after a failed connection on a restart. It’s reasonable for it to retry every 10 min and still be OK. Curious why each time I lose power for a few seconds I need to pop the breaker to get it back. Each time I do that it comes back right away


#119

Update here: I have not had any problems with my monitor going offline (other than for brief periods that likely coincide with firmware updates) since Ryan et al applied their bug fix. So far so good!


#120

Glad to hear it. Keep us posted!