First EV devices!



Hi @MattAtSense et al,

Still not seeing 2015 Tesla Model S p85d on 80amp HWPC after a month. It’s set for consistent time of day (4am). Anything else I could do to help this along? :wink:

Thanks, Mike



We’re working on fixing the known defect with the current batch of devices and on getting the next set released. We have all the information we need for now from the user survey. We’ll let everyone know once the entire categories of specific cars are released, or if more information would help.

I know it is frustrating not having timelines available, but we are making progress towards giving you this information.



Still no detection of my 2013 Tesla S85. Set to 35 amps because my power company sucks…


I have a 2016 Hyundai Sonata PHEV that I charge from a 120v outlet.


Matt - can you give an update on the EV status for the first batch of EVs?



A mitigation was released this morning for homes receiving new devices. It will take some time (up to two weeks) to propagate to homes with existing devices.

If you are still seeing the incorrect turnoff behavior in after March 20th, please let us know.



Hi everyone,

We released the next batch of cars this morning, which covers 240V BMW i3 chargers. If you have an i3, It may take some time to find the i3 in your home. If Sense doesn’t find it by the 20th of this month, please let us know.



Any update on the 2012 Model S?


[quote=“MattAtSense, post:48, topic:162”]
We released the next batch of cars this morning, which covers 240V BMW i3 chargers.[/quote]

Can you specify what cars you are now supporting? Also, how can we tell (firmware/software update #) that our devices have been updated?




Sense knows how to detect the following EVs in homes (we’re working on other EVs):

  • All 240V BMW i3s
  • Most but not all 240V Tesla Model S cars from the last three years

There is currently no information visible that shows you whether the device has been updated or not. I’ll log a feature request with our product folks, something like a “last updated” date field.



That would be very helpful.


Hi Matt,

My 2015 Tesla Model S charging using NEMA 14-50 at 40A, 240V has been “identified” and is listed in my devices, unfortunately aside from just an initial spike periodically, it doesn’t track any consumption.

Reading through this forum, it sounds like my car should be able to be identified.

Can you investigate?



I’ve talked with someone from support about this. Support will be contacting you via email about the device.



Will my Model S be found if it only charges at 35 amps, and not 40? I can’t set it to 40 because my power is flakey.


Which Tesla charger have you modeled - the 220V HPWC (wall charger) or the charging cord that comes standard with the car and plugs into a 220V NEMA 14/50 ? I have a Model S P85D and a Model X P90D that each have their own HPWCs. The signature for either one is pretty unmistakeable :slight_smile:


Hi Matt, I have a Tesla Model S75 that I purchased new May 2016. I’ve had Sense since the end of January and it hasn’t found my Tesla yet. I charge it at home 4-5 times per week for 3-6 hours at a time. I remain patient but anxious since this car is the primary (but not only) reason I purchased the Sense device. If it helps I use the NEMA 14/50 connector to charge the car on a 40 Amp circuit.


I use a NEMA 14/50. I have to charge at 35 amps max, vs. 40 because my power company sucks… 2013 S85



We released an update on Friday for 240V Teslas from 2015 and prior. It won’t matter if you charge at 35 vs 40 amps. If you receive a device in the next few days, please let me know along with how accurately Sense detects your usage.




We’re currently working on devices for the newest types of Teslas, along with Chevy Volts. I know it is frustrating that Sense hasn’t found your electric vehicle yet despite finding other Tesla Model S cars, but we’re working on it. I’ll let you know when Sense should be finding your Tesla.



It found ‘electric vehicle’ and does detect when it starts to charge, however it shows as 34 watts then shuts off right away.
My heat pump is doing the same thing it shows “on” for about 2 seconds when it kicks on, then off. (it used to stay on for duration).

Obviously, it should show 35x240 = 8400 watts. It’s also not 100% on the ‘detection’ process, it’s about 80-90%. Not sure if that matters.

Thanks for the help so far! Detection seems to be getting better.