KP115 worked 2 days now missing from Sense

I bought a few of the new KP115 smart plugs. I put the first one on my refrigerator. It worked two days and this morning I had a notification that the refrigerator was off for 45 minutes.

I checked (3 hours later after I got up) and the refrigerator was running. The power history shows it was cycling as it always does, didn’t stay off longer than normal. Looking closer at the refrigertor’s power graph, I see that it hasn’t received a single reading since 5:50 AM. The plug is still working and the Kasa app can turn it on and off. The Kasa app shows the correct power usage.

Just noticed that the other two KP115’s are also gone from Sense. (Garage door opener and workbench lights). The Kasa app still controls them and reads their power OK.

What can I do to make Sense see them again?

Sometimes, turning off NDI (network device identification) then turning it back on in Settings, will enable Sense to reconnect with the smartplugs.

The 6 plugs on the HS300 are still seen and correctly showing their usage. Just the 3 KP115s aren’t showing (they are “n/a”).

I cycled the Network Listening, but it didn’t seem to do anything. I was about to shut off the Integration - Smart Plugs - HS300/KP115/HS110 feature but paused when it said it would erase all of them. If there are no other good ideas I’ll do that.

My 2c - you can try turning off the integration and back on again, but you will lose all your history. My experience is that the TP Link integration is very sensitive to your networks traffic and configuration since it relies on network broadcasts. I you have multiple access point in your house, or if you have some kins of repeaters, those broadcasts can get suppressed causing this kind of disconnect as well.

I’m not sure the reason below is the case, but I’ll throw it in for discussion.

I’ve had a similar discussion on HomeAssistant regarding these Smart-Plugs, and some prople believe those are not suitable for non-resistive loads. The Fridge for sure is not purely resistive (only heaters are). In fact I confirmed with an old Kill-A-Watt that the cos phi is non zero. I am not saying this is the case, but it is a bit/remotely possible, also depending on how much power (real/reactive) the fridge is pulling. All of this said, yet, I’m using a KP115 on my fridge (17 years old) and have not had any issue for the past 3-4 weeks (since I installed the KP115’s).

A few other Possibilities:

  1. Are you running any 3rd part Home Automation software ( that could possibly be interfering with those plugs.
  2. Did you do a firmware upgrade on the plugs after you set them up then linked them to your wifi ?
  3. How clean is your energy distribution? Any dips/spikes in the total energy draw that might correlate with when the smart-plugs switched off?

And few more questions:
4. The missing data in Sense, is it only for those smart-plugs or are there other devices with similar behavior?
5. How’s your network coverage where these plugs are installed? I have one in my garage (for a freezer), and sometimes my wifi is spotty there.
6. Everything I’ve read (on here and even on TP-Link’s forum) is that after a power failure, the plugs revert by themselves to whatever status they were in before power was lost. So, if we believe that, power fluctuation might not be the culprit, but still, there are always extreme/unique cases.

In summary, no specific answers yet (a bit verbose/comprehensive), but more pointers into possible culprits, or areas of investigation. Good luck, and keep us updated.

1 Like

Brief aside. The HS110 uses a Maxim 71020 which does have phase compensation up to +/- 10 degrees when computing real power.

Maxim sold off their metering business in late 2016 leading to the demise of the 71020 which eventually killed off the HS110. I think the HS300 and KP115 use an STM part that also does phase compensation.

  1. I have no 3rd party software although there are many Kasa Smart plugs and switches so I do have the Kasa app.
  2. Yes, all 3 KP115s updated the firmware right after they were connected.
  3. Energy distribution is very clean at my house. Here’s a sense lab view showing 24 hours before they went offline (nothing newer is available).
  4. Nothing else seems to be missing; the refrigerator and the garage door went off at 5:39 and 5:40 this morning according to the timeline (the workbench lights were already off so I don’t have evidence of the time they stopped being received).
  5. Network coverage is excellent since I put a mesh network in mid summer. In the garage there are the 2 KP115s and I have the sprinkler controller, two light switches (HS200), the garage door opener (myQ), a door sensor (SmartThings multi sensor), and 3 smart plugs (HS105 and HS107) controlling other lights. The refrigerator is ~15 feet from the main access point.
  6. There were no power failures last night. (Coffee maker, oven, microwave and two other clocks all still show correct time). I tested the KP115s when I set up the first one. It reverts to its previous state when power is lost and then comes back. TP-Link does not provide a setting for this.

Here are two shots of the Sense power meter for this morning. I’ve marked the refrigerator and furnaces. The cursor is at the time of the signal loss.

The refrigerator is an LG with “quiet start linear motor”. (I think that means it is a DC motor). But an inductive load isn’t the culprit as the KP115 is still working. Still measuring power and sending the data over wifi to the Kasa app. The issue is just that Sense has stopped listening to all three of them.

Thank you for the detailed ‘investigative’ work. I guess one question in my mind is whether, when Sense lost the various smart-plugs, it was an issue with the plugs and/or with Sense. Maybe you already addressed that and sorry if I missed it. I have not played much with the Kasa App (I should), and maybe one can reach out to the TP-Link forum and find out if Kasa registered anything ‘suspicious’ around the same time Sense lost the plugs. If Kasa did not see/register anything, then the issue is most likely with Sense, and you might want to send an email to their tech support. If however the issue was also picked up by Kasa, then it’s either Kasa, the network, or something else besides Sense.

Again, no specific answers yet. Maybe someone who understands the inner workings of how Sense gets data from the smart plugs can chime in. My understanding is that all the data is in the TP-Link cloud, and does this point to (another possibility) an issue with TP-Link/Kasa not connecting to their mother-ship? Though, one way to rule this out is like you already wrote, apparently your other smart plugs did not see any interruption. Correct?

The Kasa plugs don’t send their data to a cloud, it’s all LAN and internal storage in the plug itself. Since all three went off at the same time I suspect the common point - Sense.

Here’s a screen shot just taken from my phone (there is no PC app) showing the refrigerator is currently in its idle phase.

Thanks for the thought you’ve given this and ideas you’re giving. I was very pleased with this for 2 days; hope to get them back online.

One more screen capture; the timeline showing both devices which were on “turned off” at 5:40 AM. (EDIT - I thought for a minute that the standby message was erroneous, but it is correct.)
Sense timeline Jan 9

I do not recall on which platform (Windows or iOS), but in one of them Sense has the ability to turn plugs on/off. This tells me that Sense not only ‘monitors’ what’s happening with the plugs, but it also can send ‘commands’ to them as well. Is there a way to find out if such commands were somehow initiated by Sense? … and that’s a question for the entire community, especially the moderators.

@drjb Turning a plug off would not affect if they are or are not appearing in Sense. It would literally just be controlling whatever is plugged.

@demiller9, aside from toggling the NDI setting in Sense as Kevin suggested, have you tried power cycling the KP115’s and/or the Sense itself?

The Sense team can correct me, but I think generally speaking, Sense isn’t doing much special in regards to the kind of TP link device it is talking to. I believe all of the plugs speak “the same language”. So all Sense is doing is saying “hey, any TP link plugs out there, if so, tell us your name and how much power you are using right now” and then it just listens for whoever replies. I don’t necessarily believe that Sense is going "ok, this is data from a HS300, so I have to do X with it and this is data from a KP115, so I have to do Y with it. I think all the plugs basically reply the same way.

I mention this as the fact that it was only KP115’s that dropped of may be a red herring that its a Sense issue and may be related to a KP115 issue. Since the Kasa website still seems to list these as “coming soon”, I can’t find any support info, but any chance that there was a firmware update for those plugs?

I know back in November, TP Link started changing their firmware to block the local access that Sense and other systems rely on, so I’m wondering if the same happend here. While I would expect if this were the case we would see more reports from other users, its possible its a slow roll out.

1 Like

@ben It seems I was not too careful in my answers and was alternating my answers between the two possible interpretations of what the OP meant when he wrote ‘fridge was off’.

  1. Plug was still connected to Sense, visible within Sense, but toggled Off
  2. Plug no longer visible/accessible from Sense

In my posts I was addressing alternatively #1 and #2. What @ben is saying, it is most likely #2

Correct? Should we focus solely on #2 moving forward?

In any event, if the situation is truly #2 always, then most likely this is a Sense issue.

Here is another possibility. Are you addressing your Sense from two different platforms i.e., Windows and iOS? I recall seeing small ‘inconsistencies’ when I started with this hobby a while back, but do not recall the specifics as I was on a learning curve. Specifically, Windows would tell me some plugs were detected, whereas my iPhone at times showed not the exact same devices.

@ben I toggled the NDI with no success. I have not toggled the Sense unit nor the KP115’s. I’ll go try the KP115 on the workbench as soon as I post this. If that doesn’t help, I can try the breaker that powers the Sense.

@drjb When I wrote the “fridge was off” I meant that Sense claimed the fridge was off, while in fact it was cycling normally from standby (3W) to on (70-80W). The first thing I tried after seeing that it was actually still on was to press the ‘power’ button in the sense app (by the device name) and that turned the smart plug off. I reached behind the refrigerator and pressed the button on the smart plug and turned it back on. The plug is visible in Sense, but it is gray and says “n/a” on the on/off button now. The Sense app will still access the power history, which is flat after it stopped seeing the smart plug.

I’ll go try cycling the power to a KP115 and / or to the Sense unit.

OK! unplugging the KP115 and replugging it makes Sense see it again.

I didn’t power cycle the Sense unit.

1 Like

I think this might indicate that we could rule out a firmware or software update as ‘breaking’ the connection between Sense and the smart plugs.

1 Like

@demiller9 Thank you for clarifying. Apologies for side-tracking here as I was not too careful with my answers/wording.

Yes, I also found out one can turn on/off smart-plugs from the Sense App but I learned to avoid doing that… Here is a bit of history (and a digression too):

I’m trying to get (a software for Home Automation) to work with all my smart home gizmos. Incidentally, has APIs available for both TP-Link and Sense. In the App, I once tried to switch one smart-plug off, it somehow turned all 7 of them off, then lost connection to all (from within I had to go and restart each one individually (by pressing the physical button on each) as Kasa also was not able to access them. I haven’t been able to figure out which is the culprit issue, but my lesson was that all these software ‘layers’ could have ‘collisions’ sometimes and one has to be careful. Now, I only turn TP-Link smaret-plugs on/off from the Kasa App … the last thing I want is to find my freezer turned off someday.

Regarding disconnecting/reconnecting the TP-Link smart plugs. What I found ‘useful’ in the past was to disable TP-Link integration within Sense, then re-enable it. This wipes out all history, but a fresh start sometimes minimizes upcoming errors. None of this is very scientific, of course and it is akin to ‘close all windows and reboot your computer’.

The refrigerator is not a plug I plan to turn off from the button or any app. Likewise, it would be rare to need to turn off the garage door opener (perhaps for vacation, but it has a ‘Lock’ feature for that purpose). The workbench would most likely be done by button press.

Again, thanks to all who participated in this little adventure. I’ll post more if it goes off line again, or perhaps an update if it continues to behave for a lengthy period.

1 Like

The Sense unit stopped seeing my three KP115’s again this morning at 8:47. All three units are actually working; I can turn them on or off with the Kasa app and that app shows their power usage with live updating. The Sense app shows all three are “not available”, “n/a”.

I cycled the power to the Sense unit in the breaker panel. It seemed to take too long to come online so I used the app to reconnect it. During the connection Sense does a network test; the test passed and reported the upload and download speeds are good and the signal strength is -60dB.

After it was back online I waited to see whether it would connect to the KP115’s again. 10 minutes went by and I decided to cycle power (unplug/replug) one of the three. It was detected right away after that. I have not cycled the other two yet, I’m waiting to see if by some miracle Sense will start to see them again.

The first time the plugs disappeared was 1/09 at 05:40:17 or 05:40:18. Today it happened at 1/12 08:47:19. There were no power glitches on 1/09 (here is the Sense Labs graph of the day).

Because they go off at the same moment but were started at different times I don’t think it is any sort of ‘lifetime’ or ‘runtime’ problem.

I suspect there is some oddity in the communication to these plugs; some initializing that gets done once but then somehow gets lost. Sense doesn’t know it needs to repeat the initializing but cycling the KP115 does it.