[Bug]: Ecobee integration fails when 2FA is enabled

Hi, new user, installed two Sense’s yesterday.

I noticed there was no AC listed under device inventory, is that normal, my two AC’s are the largest consumers of power?

Anyway, I wanted to enable Ecobee integration, but I kept on being told my password is wrong.
I verified my password by logging in to the Ecobee web portal, on login I got my 2FA text message, entered the challenge, and could log in.

I suspect that the Sense Ecobee integration fails because it does not support 2FA?

5 Likes

I think that’s still an issue right now, though someone on this thread may have tried a workaround.

I haven’t moved my Ecobees to 2FA yet because I have several integrations even beyond Sense that don’t support it yet.

I’ve had issues with this since I first installed my Sense system a few months back. I don’t have 2FA enabled on my ecobee account but still had issues with this (i.e. the ecobee sign-in page within the Sense app still tells me my password is wrong when it’s not). I opened tickets with both Sense and ecobee. Both sides said it’s being worked on, but I’m surprised it’s taking this long. The ecobee folks seem to think it may be as simple as updating the Sense app to point to ecobee’s latest API sign-in link. Maybe the fix is more complicated than this.

1 Like

I removed 2FA from my Ecobee account, and I could then link Sense and Ecobee.

1 Like

I don’t have 2FA enabled on Ecobee side but never could get integration work. Keep getting the same error message “ Something went wrong during authorization. Please close this window and try again”.

Reached out to tech support and they opened a ticket but also point to this 2FA issue which is not my case. Any one have success setup the integration? I’ve heard Ecobee changed their API lately.

1 Like

I am running into the same issue as @xndou. I just setup my Sense Energy Monitor and anytime I attempt to integrate it with Ecobee via the iOS app I am taken to an error page in my browser with the message - “Something went wrong during authorization. Please close this window and try again.”. Any idea what might be causing this or how I can fix it?

I’m seeing the same thing without using Ecobee 2FA - just a simple password. Have contacted Sense support and they are saying that Ecobee has made some API authentication changes that require Sense to make some updates.

Also have the same issue, tagging to track for update.

Joining the club, I also have this issue.

Having the same issue

We are aware of the issues with the Ecobee integration when 2FA is enabled. This is high priority on the list of bug fixes and we will update this thread once we have a more definitive timeline for a fix.

4 Likes

Having the same issue with 2FA enabled & disabled.

Hi @sense.bills, thanks for sharing.

Can you let me know the:

  • Device you’re using to access Sense
  • Device firmware you’re running (ex: iOS 14.2)
  • Sense app version you’re running

Hey Justin,

I have an iPhone XS with the newest version of the Sense App (v 34.1) running iOS 14.3. After authorization I get the ‘Something went wrong message in Safari’. If I check the Ecobee web app, it says that the Sense app is connected however Sense does not finish the handshake.

On my M1 MacBook Air I can see in the browser that I receive a 401 Unauthorized error for URL: https://api.sense.com/api/v1/integrations/oauth/authorize/ecobee/response/ios?code=xxxx_code_value&state=xxxx-state-value.

Other relevant data:

Status: 401 Unauthorized
Source: Network
Address: 54.83.17.15:443

Request
GET /api/v1/integrations/oauth/authorize/ecobee/response/ios HTTP/1.1
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Encoding: gzip, deflate, br
Host: api.sense.com
User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_6) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/14.0.2 Safari/605.1.15
Accept-Language: en-ca
Referer: https://auth.ecobee.com/u/consent?state=encrypted_state_value
Connection: keep-alive

Response
HTTP/1.1 401 Unauthorized
Date: Sun, 17 Jan 2021 04:53:20 GMT
Content-Length: 81
Content-Type: text/html;charset=utf-8
X-Origin-Request-Id: request-value-id
X-Local-Request-Id: local-request-value-id

Query String Parameters
code: xxxx_code_value
state: xxxx-state-value
2 Likes

Thanks for all the information @sense.bills.
Also, if your username is indicative that you’re a Bills fan, congratulations :slight_smile: .

Same issue here: pixel 3xl running Android 11; sense app version 34.1.

Having same issue. Getting authentication issue. 2FA not turned on.

Having the same issues, unable to verify the ecobee account. I’ve never had 2FA enabled on the ecobee account and just this past month this started.

Trying to link using Sense mobile app in iOS. I tried doing it on the computer however that integration isn’t even displayed using a safari browser.

1 Like

I, too, am experiencing this issue. I do not have 2FA enabled with Ecobee.

Same issue here. Pixel 2 with Android 11. No Ecobee 2FA