Kasa HS300 not reporting but KP125 are?

Yes - Somewhere in the middle, one of the posters, @Offthewall I think, did try static IP addresses. Did not seem to cure it for them AFAIK. I’m afraid that I might have muddled my fix because in order to set up the ping plots, I slowly moved many of my most problematic smart plugs (not all), to fixed IP addresses (reserved leases). I still see occasional dropouts, but not for prolonged periods as others have seen. You can see some drops to zero in one of my most problematic plug below, but nothing for more than couple of minutes.

I’m not completely convinced that it’s a simple as IP address musical chairs. I have seen cases where the Kasa app locks up when requesting power data, maybe when I have cloud access turned off for that plug and Kasa was forced to talk locally to the problematic smart plug. And In my case, for a while I was seeing Zombie smart plugs that were singable from my router/gateway, but not from my laptop, via the same IP address (smart plug IP MAC had no matching IP address in the laptop’s ARP table).

Yes, at some point I had the Sense and all 5 KASA plugs on static IP’s. That did not solve the problem for me.

What about the sense meter and the plugs all on static IP’s? Or even a vlan / and everything static?

I’m looking at my logs and my HS300 was reassigned another IP 2 days ago. So I can’t see it not being a LAN related issue. I didn’t reset anything but I changed my lease times to 5 mins… If the HS300 is ever is assigned the orginal IP, my “fan” should show some sort of usage within sense. And if the plugs change… they will stop showing usage.

I had the sense meter and the Kasa plugs set to static IP’s. They were still on the same Vlan as the rest of the network. At one point I had the sense and just the plugs on their own totally separate wifi/router but they were all DHCP in that setup. In each case the Kasa plugs would go NA to the sense on a regular 5 day cycle. Changing DHCP lease times had no effect on the timing.

I have since taken all the Kasa plugs out and replaced them with Wemo plugs which I belive the Sense also uses local LAN communication with. They have been working flawlessly for months.

2 Likes

I’ve had zero outages between Sense and my KASA plugs in almost 2 years. Wonder what I inadvertently did right??? Or, are these problems limited to a very small number of users with something unique in their LANs?

1 Like

@andy , that was my experience with my Apple-based, but very outdated, 5 access point wired network (1 Extreme base station as gateway, 4 in bridged mode as APs). I started seeing the persistent dropout issues when I upgraded to a similar topology of new Ubiquiti gear.

The Device Power Meter below, for my most challenging HS110, shows the change. N/A dropouts show as drops to zero. I switched to the Ubiquiti gear in early June, and soon had a long dropout on many of my HS110s.This one took the longest to reset since it is in the attic, and requires a lot of effort to access. Since then, I have had seen few more “zombie incidents” where the HS110 essentially disappears from every device except the UDM/router. Since about late October, I have done two things - once-per-minute
pinging of the problematic smart plugs, plus moving them slowly to fixed IP addresses.

My theory is that prosumer networking gear has many more configuration switches and probably enforces some protocol requirements more rigorously than consumer networking products that are aimed at out of box full-functionality. Apple gear, for instance, automatically has everything needed for mDNS always turned on.

I’m not a true networking expert and having fully reimplemented all the details of my former Apple network - I originally had my IoT devices on the “Guest” network which Apple implements via a separate wireless subnet and hidden VLAN. I haven’t done that yet, partially since Apple only offers that network as wireless, so Sense couldn’t “see” wired activities in my house - Hue integration, plus switching of smart TVs. Partially because I’m trying to slowly tune everything in the house.

1 Like

Well… everything still had the same IP in the morning. So i’ve brought one of the KP125 to work where I get to work a create a matching ssid from my house/ bridge to wan. My phone autoconnected… then plug in the KP125 would not connect. I dont even see the mac address in my logs/ no dhcp request… nothing. I scrapped the ssid and connected it to default vlan

I deleted the plug out of my Kasa app and tried to add it back (without using homekit). Specs say this can be added without using homekit, but following the instructions in the app or on their site is defiantly using homekit within the Kasa app. I ended up to add it like a KP115 in the app which did add it to my network but the app shows it failed. The plug shows up in my app now but says unavailable. I can ping it and its a busy little plug for one that didn’t successfully connect to kasa.

First 5 mins, guessing its try to reconnect to kasa (via AWS). Might have to try a KP115 since I have no homekit hub at work.

@Offthewall Does the Wemo plugs return to their previous on/off state if the power goes out and are they compatible with smartthings? And when you say 5 days… Like exactly 120hours?

My plan was to install this plug at work then check back 5 days later.

1 Like

Not sure about the other questions, but unless Wemo has changed something here, no, it does not revert to the previous on/off state if the power goes out, it reverts to off.

1 Like

What is you home network like? I feel that mine is very basic… I am very adamant about no servers/ no desktops and residential equipment at my house. I have a netgear RAX120 that I am running netgear firmware… I even used the wizard to set it up, also in the network is a Ubiquiti edgemax poe switch (for cameras/UNVR)… in my garage i have my old netgear router that functions as a switch and wireless access point. I do have a z-wave hub (smart-things) that is more complex than my home network. Only nas I have is a usb HD in the back of my router which does my itunes backups.

The reason is…at work I deal with this BS all day along with a ton of PCs, thin clients, IP printers/ redundant point to points, IP-printers over 100 laptops that are weapon/ NCIC terminals that report “AVL” via NEMA com ports and require MFA and bitlocker and a CJIS vpns per unit, self hosted AD controllers, air-gap networks, azure accounts, door controllers, cameras, LPR’s, SIP phones with IVRs, backups, AV on everything, raid controllers … fiber, fiber fiber. Something is broken everyday, or UI’s got a data breach, or a windows update broke everything, permissions and personnel are changed everyday, geekers stealing copper or from towers. Had one knock a 385 ft tower down the last week. Probably have 40 users that will open any attachment from any email or link on fb that they won something, probably 20 that cant remember their password after a 3 day weekend.

1 Like

I feel your pain even though I don’t have to do the work. I decided to try to sort out my ping responses by charting a histogram of the log10 for each devices’ response times in microseconds, so a 6 is a response time of 1 second. All of this is measured from a wired server in the middle of my network (tied to the main switch).

I also did a corresponding table of the # of ping response failures over the past few days.

As you might guess from the numbers, IP addresses ending in 1, 11, 215 and 239 are all parts of my networking infrastructure. Interestingly 233 is also infrastructure, the main switch. Not quite as responsive. The biggest disconnectors, 17, 93 and 15, are one problematic HS110, my downstairs Ecobee and my lone KP115, respectively. All the rest are either HS110s or HS300s.

If a 6 is 1 Sec… 5 is 833ms? Is192.168.1.93 is your ecobee?

And are you using dnsmasq ?

Not sure if this may help with the technical of TP-Link plugs or if it could be useful for the networking geeks on the other thread: [BUG] - All five kp115 smart plugs went offline according to Sense but are still really on

Throwing this link out there in case it might: Reverse Engineering the TP-Link HS110 | softScheck

2 Likes

So 833msec would be in a bin between 5 and 6. And yes, Ubiquiti’s built-in DHCP and DNS for the UDM uses dnsmasq. 93 is the Ecobee, the one with the long tail out beyond 1 second. I can expand any of these if you have more questions.

No the Wemo plugs default to off after a power failure which is the only (somewhat) major failing. I have a couple of Home Assistant routines set up that cover the most common scenarios of the Wemos loosing power and turn them back on when power is restored. That has worked though several of our all too frequent power glitches here.

The five day Kasa thing was bizarre and the genesis of this thread. It was exactly 5 days PLUS 10-20 minutes each time. The time would creep forward on each cycle.

One more interesting view - here’s about 15 hours of the most recent ping plots. The Ecobee is the device with the unique up-spike then ramp-down pattern for ping times. Every so often I see a strange spike in ping times to my APs, that is followed by disruptions in the ping times for all my smart plugs (inside the green vertical lines). The ping time spike does not occur with my main switch or with the UDM (router/controller/switch/AP combo).

The 2nd link was actually pretty good… went much farther than I would have. I was just going to watch 5-6 days of traffic. The one thing I would disagree with in the write up was the “useless LAN encryption”… not everyone has a secure firewall. I’m sure most of these “WiFi plugs” are put on very unsecured networks.

The cheaper wifi plugs/ switches will leave your entire network exposed. I’m sure the Kasa/ TP-links have also had their fair share of flaws. Which is why those running several of these, I would suggest even putting them on a VLAN and setting up some rules…. Also why I prefer a zwave/ zigbee for home automation… the protocol is closed and stable. You are also relying on a ton of cloud networks for their security when putting 50+ smart devices on your network I promise most these companies are breached on a daily basis, even when they know it, they aren’t going to tell you. Then on top of that, if the company closes and it’s locked to a cloud, then it’s useless.

1 Like

Of all the issues I have had with 29 KASA devices, this was never one of them.

All my units are DHCP but set to reserve/static IPs.

@andy As you also have had no issues, are you reserving Static IPs for the devices as I am?

Are you using 192.168 or 10?

1 Like

So, Ive left this thing plugged in…I see a lot of traffic from AWS cloud servers and nothing alarming. Strange that it has this much traffic but not making contact to kasa.

However…Right at 5 days (120:0:0) the KP125 decided to become its own DHCP server and assign itself a class C IP of 192.168.0.1. The network its on has no class C IP’s (192-223) anywhere at all. The firewall/ DHCP server has the entire class C range blocked. At (120:10:0) it re-grabbed the 10.50.17.39 IP.

I assume that @andy router is at 192.168.0.1 where my house … I did change my netgear’s LAN to 192.168.1.1 and I see that @kevin1 is also on a 192.168.1.x. Guessing most people here are using a 10.x.x.x.

Im not sure why kasa has this thing doing rouge routing right at 5 days and Im not sure why using they would use the most common dhcp IP, then Im not sure why that doesn’t cause more havoc on andy’s network than ours, it actually probably is for 10 mins… But I assume that must be crashing the LAN hub between LAN sense and LAN kasa while testing LAN communications. I tried to ssh into the KP125 but it wouldn’t let me in. I thought that all kasa and tp-link plugs all had an open local API… just would be interested in view the json file at this point.

1 Like

Very interesting. Thanks for the deep research.

And yes, no SSHing into Kasa smart plugs - they only respond to two protocols AFAIK - their smart home protocol and debug protocol.

I’m still not sure that I figured this one out. I have 2 of the KP125 and only 1 drops like clock work and the other one doesn’t never drops. My HS300 drops 1-2 times a month. I’m sure that this is an issue with KASA/ TP-Links routing process the destination IPs that is communicating with are almost all AWS service which is hosting their cloud services. Since the KP125 appears to not currently have away in we will have to hope someone at TP-Link figures this out.

I did get a new raspberry Pi 4 for Christmas that I’m going to install HA on it, Im pretty sure I can come up with an applications to make the ones dropping. To auto reconnect.

1 Like