Sense Detected Previous Set of Kasa EP25 plugs, but not the New Ones

First batch of smart plugs got added just fine. Decided to buy a couple more several months later during Black Friday sales. These new ones don’t get detected in Sense at all. Even though they set up perfectly fine in Kasa app and HomeKit, and are on the same Wi-Fi as the old plugs, which showed up in Sense almost immediately after turning on the TP Link connection in Sense.

New firmware in the new plugs, I noticed (default state, auto timer) in the new plugs. Definitely not risking the firmware update on the old plugs in case that was something to do with it.

1 Like

Could you confirm the model of your new plugs? There are a lot of models that look the same, but not all report energy to Sense. For example, the new model KP125MP does not, even though the older KP125 model does.

1 Like

It’s the Kasa EP25, same exact model as the previous four.

You mentioned that the firmware is updated. What is the firmware version as reported in the Kasa app? For curiosity, what is the Model and Hardware version reported there? If you share a screen capture of the Device Info tab, be sure to obscure the MAC Address before posting. I’m not sure why, but apparently sharing that info on a public forum is bad.

Confusingly, the older one shows v1.06 while the newer one says 1.01. But the hardware version is higher for the newer one v2.6, versus v1.0.

Here’s Sense’s take:

This issue is specifically with the EP-25, particularly the newer ones. It seems to be related to some API changes, and we are working to investigate this issue. However, at this time, I am not sure about the future usability of EP-25 plugs.

While I don’t have a timeline for when this issue will be investigated, I will keep you informed when I receive more information or have any further questions.


I’m having the same problem with brand new EP25 (US) recently ordered from Amazon as a 4-pack. Not recognized by Sense. Been trying for a couple of seeks now. Have moved the devices around. Works fine with KASA app on iphone 12 mini running iOS 17.1.2. Getting this on 3 of the 4.

Firmware version is 1.0.1 Build 20230614 Rel.150219
Hardware version 2.6

1 Like

Welcome to the forum, @cafelizardo . Thanks for confirming that the problem is not limited to one user. I don’t have any further suggestions for how to fix this, other than opening a support ticket. Data you report directly to Sense may help them as they investigate the issue.

1 Like

Well, at least you got the one plug to work? At least that implies it’s not too far removed from getting the thing to work. Tech support thinks something changed in the TP Link APIs, which is unfortunate since the EP25s are likely the cheapest HomeKit smartplugs by far among the models that Sense supports, and likely the most common. (They’re also very responsive, reliable too).

Sorry, what I meant was I had only tried 3 plugs at the time. I have since installed the 4th, this time using the “HomeKit Smart Plug (BLE)” option instead of the “HomeKit Smart Plug (Wi-Fi)” option. Both list EP25 in small print but I hadn’t noticed the (Bluetooth Setup) until last night when I was reviewing the instructions that came in the box. As of this morning it had not identified any Kasa plugs so after reading some of he other forum topics I went ahead and disabled the TP-Link integration under settings and turned it back on. All four plugs report the same firmware and hardware version.

I believe I may need to wait up to 48 hours but it was not clear to me if I have to periodically cycle the power via the KASA app or not. I was going to wait a couple of days before trying to open a ticket.

Well my take since I am in the same boat is this, if this plug is not working and identified by Sense, then Sense should be removing this model number from their recommended smart plug list until it is resolved.

Its very frustrating that it isn’t identified and the response I get from support is that yes, we know it isn’t working, and truthfully, we are not sure it will ever work again.

Sad, but since I’ve had Sense, going on what I believe to be 4 years now, I have really seen no updates to further this product along. I see a lot of new partnership announcements and collaborations with other vendors, but as far as this product goes, it seems lost to time. Sad am I, I have enjoyed it, but as a long time user I just feel this product leaves me feeling like its no longer being actively developed.

I am having the same issue with the KP125M model as well. firmware is updated and on auto update, Firmware version 1.1.4 build 231019, hardware version 1.0. hopefullt Sense figures out a way to get this model into the program.

1 Like

Same issue here, with the new EP25, specs:
Firmware Version 1.0.2 Build 231108 Rel.163012
Hardware Version 2.6

Previous models of EP25 worked with the following specs
Firmware Version 1.0.13
Hardware Version 1.0

1 Like

A post was split to a new topic: How Do I Change Notification Email Address

Just wanted to chime in that I’m experiencing this as well. Have been running Sense for a couple weeks now and decided to buy the 4 pack of EP25 plugs. As others have mentioned, they have the 2.6 hardware and do not work with sense. I found that the Home Assistant community is having the same issue. Maybe if they figure this out first Sense can jump on the bandwagon.

I intended to share a link to the home assistant GitHub community where they have made progress getting access to the data on the new plugs. Apparently links are not allowed or I am too new to post links. Searching for “home assistant Kasa 2.6” will pop it up pretty quick, however.


Same issue here. About 20 EP25s work fine, hardware version 1.6. New pack of EP25 Version 2.6 do not work with Sense.

1 Like

Same issue as well I have an initial set on HW 1.x no issues. New order of the same model (EP-25) but newer HW 2.6 will not work with Sense.

1 Like

I would like to toss my hat in the ring too, seems all of my KP-125 plugs no longer work in sense, rebooted everything, disabled Settings > Connected Devices > TPlink > Disable waited a few and reenabled and now it does not even find them. Everything works fine in the Kaza / HomeKit app.

HWV 1.0
FW 1.0.13

1 Like

My older KP-125 still work…so far. If Sense is using the open source “Home Assistant” library for this integration, they have identified the root cause and seem to be close to fixing it. (seems to be a change in the encryption used in the newer TP-link plugs) Search for "** EP25 is no longer supported #30027** in Github and the linked topics.

1 Like

Good Afternoon,
I just set up a bunch of smart plugs that are not showing up in sense. The pugs are updated to the latest firmware and are on the same network as my sense control unit

Good Afternoon,
I just set up a bunch of smart plugs that are not showing up in sense. The pugs are updated to the latest firmware and are on the same network as my sense control unit