TP-Link issues

#1

I am having issues with my TP-links. Only 4 out of my 6 HS110’s are showing on in the sense app even though all 6 are on and I have 3 HS300’s and all of those are showing off in the sense app even though they are all on. I was told to remove and re add them in the Kasa app and make sure the firmware was up to date so I did but still not showing up correctly. I also went to settings/My Home/connected devices and then to the TP-Link section and disabled TP-Link but when I went back a few minutes later and enabled TP-Link the devices showed back up in the Sense app but populated with the old names and still showing the incorrect on/off state.

#2

When I had to remove mine I had to completely delete and reset the device to keep Kasa and sense from remembering the old names

#3

Well I deleted them in the Kasa app and had to go back through and discover them again as a new device and made sure they had the current firmware. I just turned TP-Link discovery off in the Sense app again and I am going to give it about an hour before i turn it back on. Maybe it just needs time to drop the info before re adding.

#4

What you had happen with the 300’s is similar to a problem in having with another T P Link product that is t supported by sense. The plug works fine in Kasa but when using with Alexa, it shows off all the time. Alexa won’t show the plug as on and won’t allow me to turn it off. I can manually or through Kasa, turn it off. Then I can use Alexa while showing off, to turn it on but it still shows off. Their support is well aware of the problem. It sounds similar to what you are experiencing unless I’m misunderstanding.

#5

So i went back into the Kasa app and removed all 3 HS300’s and then turned off the TP-link discovery in the Sense app and waited a little while and then re enabled the discovery app so only the HS110’s would be discovered in the sense app which they did just fine. I then went back to the Kasa app and added only 1 of the HS300’s and when i went back into the sense app I got the notification that it had found the HS300’s but was displaying all 3 HS300’s info BUT it was the old info with different plug names and not the new names that i gave a few of the plugs and 2 of the HS300’s were not added yet so its pulling the info for the plugs from either the data on the app or from the sense server.

#6

Oh and when i re added the HS300’s I went into my alexa app and everything shows up correctly in there and I was able to go into each device in the alexa app and disable control from that app so that i can only turn on and off from the Kasa app

#7

I think what worked for me was turning off T P Link In Sense. Uninstalling Sense App. Then I went to Kasa and removed device. When prompted to keep setting in Kasa when it was rediscovered, I setup as new with new name. Went and installed Sense again and followed steps to enable T P Link again.
The information must be cached with Sense and it wants to revert to old name.
I am doing the opposite as you and I’m controlling from Alexa only. But do t turn off remote in Kasa or nothing can control it.

#8

I had wifi issues with my TP link products. They didn’t like my Cisco WLC wifi setup. Adding multicast support helped a little(They worked for a short time), however, I had to revert to an older system that didn’t block some of the traffic(I am sure that my WLC setup is blocking something, I just don’t have the time to work out what).
I have the sense and TP Link devices connected to one WAP and everything has been fine for several weeks.

2 Likes
#9

I think you might be correct about the app caching that data and that’s what’s giving me such a hard time. When you uninstalled the sense app and reinstalled it did you lose all your data from sense or did it just repopulate all the data usage and things like
that?

Thanks,
Mike

#10

Nothing was lost in Sense as far as I could tell

#11

Have you reached out to our Support team on this?

#12

Yes last week but it’s been a slow process getting it fixed so I posted here to see if any users might have had a similar issue with a possible fix

#13

When it happened to me @RyanAtSense I didn’t
Mention it to support as I felt this was how it was designed so someone would t lose the history if they had to reinstall for some reason. I could see where an argument could be made either way.

#14

I just went in a turned off TP-Link discovery, logged out of the app and deleted it then waited a few minutes and reinstalled it and went in and turned TP-Link discovery back on and now waiting to see if it will locate the devices correctly this time. I’ll let you know if it works

1 Like
#15

And it just readded all the TP-Link devices with the old info again :triumph: I also have to go and turn off control for each device separately and with 25 TP-Link devices it’s kinda annoying and wish there was a feature that would let me decide if I could default that option to off or an option to turn control on and off for all devices at once.

#16

Sounds like a pain.
Are they all showing correctly now?
Screenshot show N/A bit wondering if they catch up and display the proper on or off status?

#17

So it’s 7 clicks once in the device window to disable the control button and at 25 devices that’s 175 clicks to disable the on/off buttons on all my devices and there is a slight delay between some of the clicks. I didn’t quite mind when it was only 5 devices but at 25 and the button locations in different locations when clicking them can become quite annoying especially when you’re removing and re adding 25 devices multiple times a day to try and fix a issue with no success

#18

No it didn’t. All plugs are on and the names are showing as the old names

#19

With nobody else saying much it sounds like this may be isolated to you right now. I would send a very detailed report to support through email so you can include screenshots.
I have found by detailing an issue, it cuts down on back and forth communication and they usually find the problem and have it resolved when they answer the first time. You might have to wait a few days and that is frustrating but maybe they can get you back going again.

#20

I should rephrase that, the HS 110’s are showing the correct names and correct on/off state as being on but the HS300’s are showing the incorrect plug names as well as the wrong on/off state being that all of those plugs are currently on but showing N.A. in the sense app. It’s as if the data for the HS300’s isn’t able to update on my account properly and this started about a day or two after the latest update to the sense app when the HS300 discovery was added. About a day or two after they showed up in sense a couple of them started showing up as off and then a few more and once I tried to disable and enable the TP-Link everything started showing up as off or na