Data Gaps in Timeline/Meter


#1

Does anyone else get gaps in their timeline. For about a week (unit installed for a couple weeks now), I have been seeing 10 minute gaps, sometimes up to 15 minutes in the timeline. Seems to happen at random times, but they are there. You can see that while it is “dropped” it registers at -1w for the time frame. It appears to happen everyday. I can’t find a day where this doesn’t appear to happen. Some days more than others. A few examples below:

I have emailed tech support last week but have not heard anything back in regards to it. I also know that it isn’t a wifi issue for that time frame as the access points log shows very high signal strength. It happens on the web app and the iOS app as I can see the gaps on both.

Anyone else have these anomalies?

Thanks


Detecting Electric Vehicle (EV) devices
Missing Data Continuously
Missing Data Continuously
Lots of gaps in meter line today
#2

I have an open ticket with support, nearly three weeks, same issues:)


#3

I have reported the same to Sense support. Seems to happen primarily when I have a real-time power meter display up on one of my devices.

Like your issue, @quietminded, it has been going on for about 3 weeks, since around Dec 20th, I have 14 smartplugs and a Hue system connected and in service. Are you guys using smartplugs and/or a Hue ??


#4

No smartplugs or a Hue system as of yet. Was going to add some in but figured I should make sure that all is working as expected first. Admittedly, I have the real-time power meter on more than I care to admit to.

Glad it isn’t just me seeing these issues,


#5

Just chiming in to say I’m also having the issue, seems to directly related to the real time meter. Using hue and hs110s.

I’ve opened an issue with support, I would suggest anyone else noticing do the same.


#6

Just another example. Quite annoying actually…


#7

Same issue here too. Hopefully it gets resolved soon.


#8

@ken2 and @anacortesplumeria:

Do these issues seem to line up in time with your use of real-time app functions, like @kevin1 and @mattlebaugh? In any case, please submit tickets to Support, but if you’re finding them lining up with real-time functions, definitely let them know about that.


Missing Data Continuously
#9

Yes, mine seems to line up with real-time app functions. I’ve submitted a ticket with support.


#10

Hard to really answer that question. For instance, first time I fire up the app this morning to look at it and I am immediately hit with a 14 minute gap in the timeline. It then proceeds as normal (for how long I’m not sure, all I can be sure of is there will be multiple of these per day). My guess is it would have looked the same in the web based version as well since the gap is shown when looking in either location after the fact.

So I guess I have to say it does line up with the use of real-time app functions, since that is what I am doing (or at least the real-time is the page I head to first upon inspection, web or iOS based).


#11

actually I’ve gotten a gap this morning in the android app and the web app… shows the same time… 12:46:44 to 12:47:11… not even a full minute, but noticeable…


#12

I’ve been seeing similar gaps for the last few weeks now, in the “Now” graph in the iPhone app, and the “Meter” view at home.sense.com.

When I mouse over the gaps, it displays -1W for consumption, and +1W for solar production.

I also have a support ticket open.


#13

Yes, I have seen these data gaps several times recently and yes they do seem to match up with times I launched the mobile app on my iPhone. It is weird because it is if Sense had just taken an outage just before I launched my app. Data now and going forward seems to be fine, but some window prior to my app launching is missing.

I was curious if it was some kind of data synch issue from the Sense servers down to my iPhone and so I just deleted the app off my phone and re-installed it but the data gaps are still there and are identical, so my conclusion is that it is not a local data storage issue but rather the Sense server side has somehow lost data.

Also note, that I have no reason to believe my home WiFi or Internet has had issues at these same times. I have other monitoring that should have alerted me to that.

It is kind of a bummer since generally when I launch the app it is because I want to go look at some power event that just happened or is happing now (like charging my car).

I am curious to hear what the issue is when it gets run to ground!


#14

I noticed another one this afternoon… since it doesn’t give any data from solar production or consumption, my first thought is network… not necessarily my WiFi or home network, but since this data has to go out to the internet, we are dependent on each and every hop (jump from server to server) along the way… for me, my trace route from my network to Sense servers:

in my case, I’m only 13 hops, but my xfinity internet service goes from my home in Visalia and goes north to Sacramento before it goes to the Bay Area, where the final server is on this list… I know I’ve also traced to Los Angeles, which ends up about 18-20 hops and still has to go north to Sacramento (my xfinity/comcast main hub) before heading south to Los Angeles… so if any server alone the way has an issue, my data could be lost…

now all of that depends on the amount of RAM/cache that Sense has, how long it can go without contact and still get all data to the server… where the server/front end that I get the data from is the same server that my data goes to… there are alot of unknowns here… it could be too much data coming from all of us at the same time and not enough server bandwidth… could be a delay in a router… heck, the Bay Area has a lot of internet outages…

anyway, I will monitor it further and see if I can see some similarities… in the mean time, I have a ticket open with support as well…


#15

I have a feeling that the sense unit is running “behind” when this happens. When you open the app, it demands data for real time, dropping the data that was not yet processed or maybe not yet sent to the cloud. From this point forward, sense is running close enough to real-time it isn’t an issue for a few hours until it slowly drifts behind again.

This would explain at least explain why the data gap ENDs when you open the app.

I went 24 hours without a dropout by not opening the app. Downside is when I opened the app to see, I caused a new one. :frowning:


#16

Sounds plausible, but in my case these “gaps” can be as long as 15 minutes in length. I would hope that it has processed the data quicker than that. I have noticed that others have had much shorter “gaps” than that, but on average, I would have to say in looking over the data, the gaps I have been experiencing are in the 10-15 minute range.

Hopefully someone from sense can chime in here with an overall update as it appears to be happening to a number of individuals.


#17

15mins is about average for me as well, some shorter, some longer. I’ve had one that was an hour before.


#18

I have been seeing these for nearly a month now. I also have a ticket open and a large segment of tplink plugs in use.


#19

mine doesn’t coincide with apps running… I tried it, had laptop & chromebook running web app, and android app on my phone… even doing multiple open/close/open… never had a hiccup… I have 2 gaps from earlier today… haven’t noticed any other issues with live meter…

we all must remember that our apps don’t talk to the Sense Monitor in our homes directly… the Sense Monitor in our homes only talks to the data servers that Sense has for storage… then, our apps, web or mobile apps, all get the data from those sense servers… so there are alot of things that happen in the background that are just beyond our control…

not to keep harping on the network thing… I tried to bombard my Sense monitor with ping requests… on average pings were 6-100ms, but I did get some requests as high as 300-500ms with 3-5% packet loss… makes me wonder about the reliability of the Texas Instruments WiFi controller in the unit… I’m going to do some more testing… but even bombarding it on my local network, I got zero issues on the live meter…


#20

I’m not sure your issue is the same. Id keep checking your network if you don’t see it related to real time usage.

This has been going on for about a month. Several of us have already dug into the network side of this issue in other threads/PMs. I at least have ruled my network out.

This is true, however the request is likely relayed back to the monitor from their servers when you open the app.