Power Quality Database Down - Page Data is Stale

I took this screen shot on Tue, Sep 12, at 8:57 AM:

The current voltage is updating, once per second.

The graph stopped updating more than 24 hours ago. When I reload the page, it does not change. I tried power-cycling the Sense unit, restarting my browser, flushing cache, all that usual stuff.

The “Last 24 hours” data has not changed for many weeks. It is wildly wrong.

The “Voltage Dips & Spikes” data has not updated since the power company fixed their lose neutral, on Sep 1. It is possible there have not been any dips or spikes since then. The download file did not include 30 days, even before Sep 1. The oldest row on that file is Aug 17, just 14 days before Sep 1. There were hundreds of dips and spikes between Aug 2 and Aug 17.

The lack of updating the graph suggest the database is not responding.

This voltage graph was helpful to diagnose the lose neutral, which is now fixed. I do not currently need to use this page, since my power quality issue has been fixed by the utility company.

Hi @SteveHansen ,

Great that you were able to solve your spikes and dips issue wit your utility. A few things to know about the Power Quality page of the app/web app.

  • The Power Quality graph is not real-time or even close. It’s done by a batch process today, so it might only be updated a few hours to a day or two after the current day. So seeing a graph from a couple days ago is not unexpected behavior (mine is similar, showing the 10th-11th). But if the gap continues to grow past 72 hours we should let @JamesDrewAtSense know.

  • Your last 24 hours min and max sustained do look a bit dodgy IF compared to the graph and the info in the Voltage Spikes and Dips section that seems to show everything is fixed. Then again, there is a difference between min sustained and max sustained values and the instantaneous spike and dips on the bottom where Sense uses 108V floor and a 132V ceiling. We should ask @JamesDrewAtSense and @JuliaAtSense to give us more info on current operation of the Power Quality page. If there is a real “unchanged” issue, you should file a ticket.

  • The “Last 30 Days” panel on the bottom won’t update with new error data if your utility fixed the issue and there are no more dips or spikes. For example I saw a couple issue when we had an outage on 9/4, but nothing since. The count of issues won’t dip until they start dropping out of the 30 day window.



I 2nd what @kevin1 said.

Based on the graph I see in this image, it doesn’t look like it is related to any known issues with power quality at this time. If you do feel that this doesn’t match your power quality, you can let me know.

The issue we have for some users with power quality at this time would look more erratic and then be resolved (at least temporarily) by a reboot. This doesn’t match up on that issue.

Let me know though, if you need any clarity. Thanks again have a great day!

Right. The current and recent power quality is good. That is not the problem.
Since the power company fixed their wiring, I have just been looking occasionally to confirm that it is fixed and stays fixed.

The problem is only that, the Sense Power Quality page has some issues, including that the graph stopped updating on Sep 11, at 6:58AM. And the Last 24 hours data has not updated for about a month. If I had a new power quality problem, now, this would not be helpful.

Just for grins, here is a graph that I captured a few weeks ago:

To: @JamesDrewAtSense James, @JuliaAtSense

My voltage graph - which was updating every 24 hours on a regular basis is no longer updating. It has been 3 days since the last update. Would you please investigate.

As of 9/14/2023 8:50 AM CDT

1 Like

@JamesDrewAtSense , looks like updates are stuck again, or maybe delayed by more than 72 hours. Screenshot from today is the same as 2 days ago.

Should I file ticket ??

1 Like

Hi, sorry I didn’t reply right away as I was hoping for an answer instead of saying, “I’m looking into it” but I just want to say that at this time, I’m looking into it.

Power quality with some sport checks seems to be updating fine many but as it is not always a consistent process for everyone (again, Sense Labs, is still a fairly manual labor-intensive process), these things can happen.

I’ll check back after the weekend and see if it has not been resolved yet unless I hear anything in the next few hours worth sharing.

Thanks for your patience while I work to help you.


@JamesDrewAtSense, The Power Quality page is still not updating for me. Last update was Sep 14 7:58AM. Time now is Sep 18 5:00PM. That is 4 days and 10 hours. This page was updating about once an hour, for about 6 months, while I was figuring out what the problem was and then convincing the power company to fix it.

We had a transient power event here on Saturday (Sep 16 5:47PM), that knocked one of my breakers off. There was a thunderstorm in the area. I was kind of hoping to find that event as a new spike and/or dip, at the next update. Since the power company fixed their issue, we haven’t had much to look at, here.

Anyway, thanks for looking at this.



I just wanted to let you know we are looking into the delay in power quality updates. I’m working with the team, and they are going to investigate it further tomorrow.

If you don’t hear from me in a few days, just make sure to mention me again and ask for an update here, and I’ll tell you what I have. Also, if you find power quality is updating before I reply, let me know.

Thanks again for your patience while I work to help you an everyone else here!

1 Like

@SteveHansen , Looks like Power Quality is back updating again, at least for me.

Screen shot on 9/21/2023 at 10:52 AM CDT - My Power Quality Graph is not updating.
It’s been 6 days since my last update.
@JamesDrewAtSense Would you please investigate. Thanks

1 Like

I got an update at 7:58AM, yesterday. But nothing since then.

Looks like the batch job runs, once, each time it is manually started. But it is not running continuously, or on a schedule. If I was still administering linux systems, I would guess that the cron job has a problem.

1 Like

@SteveHansen , look to @JamesDrewAtSense for more information. He’s still investigating. Since it’s cloud pipeline stuff, I suspect it’s something closer to an Apache Airflow problem. And maybe one failure in the queue messes up all the succeeding jobs I that particular queue.

Anyone seeing delays again in the graph? Mine is still showing September 16th, and I just had our utility out for some work to address spikes.

1 Like

yes, mine is lagging 3 days back currently, we shall see if it continues forward with date/time or its stuck, prior it was only a few hours behind.

1 Like

Mine is saying Sept 23, 18:45 PM. Both time date is wrong.

Since it’s 20:41 PM

@Marc615 , @danderson , @kolia0255 ,

I think the current feedback from @JamesDrewAtSense is that the Power Quality meter should be updated every 24 hours or so, so that we’ll always be a day or two behind - definitely not realtime in this incarnation !

Right now, I’m seeing a run of the Power Quality meter early in the AM (2:58AM Pacific Time to be exact). But I have seen charts from 4:58AM and 9:58AM recently as well.

Thanks, it seems to have rectified itself in the last couple days and is fairly up-to-date again. I am however still seeing a higher than usual number of spikes showing in my data – is the issue from last month with spikes back again? I have a Ting monitor as well and its graphs are not reporting these larger spikes. I did unplug/restart my Sense a few weeks ago.

@Marc615 ,

You might want to try the power cycle again, just to be sure. But I’m not seeing any spurious spikes or dips. I generally have pretty stable power, except when we have tree branch driven outages.

ps: One again, the period end-time has moved, but the Power Quality display has been updates so it’s late than a day old.

Hi all,

So, for the folks who asked me last week about their power quality not catching up, I checked, and in all cases, power quality is now updating as expected.

Let me know if you are here because you find yours is not updating.

Thanks again!