SOLVED: Can't login to the forums while mobile

Had some downtime at work today, so after obsessively watching my sense app for 10-15 minutes seeing what was happening when nobody was home (LOL) I thought I’d login to the forum.

I soon discovered that doesn’t seem possible. When I visit via any browser on my iPhone (I tried multiple) I can see the index and all, but when I tried to log in my iPhone just opened the sense app…and did nothing, except display my timeline.

As mentioned, I tried Chrome as well…same result, can’t login, just opens the app and dumps you to the timeline/“Now” page.

In the app itself I navigated through the UI (Settings/Help/Community Forums), it shows the forum…but once again, as soon as you click the “Log in” button you just get dumped back to the Sense app timeline/“Now” page, and nothing more.

So, it seems that there’s no way whatsoever for me to get logged in while mobile and participate in the forum.


1 Like

I’ve been having the same problem on my iPad for months but never bothered to report it. As soon as I click on Log On button, it just jumps me to the web version of the app presentation.

@oshawapilot, put your phone browser in desktop mode. Before clicking login. That may help. On Android we can remove default app setting per phone app. So in the Sense app, I would just remove anything listed under “Set as default”, it we can Clear Data, Clear Cache. I dunno if iOS offers that, though.
At work we have a proprietary app and iPhone users actually have to uninstall the app (like Sense app) then reinstall the same app to reset those options.
But try using your browser in desktop mode first.

Had the same issue this weekend.

The community forum software did not respect the request for desktop mode…which was very frustrating as I have a particular hatred for mobile versions of websites…but that’s another story.

Deleting the app and reinstalling would probably solve the issue, but that seems like a horribly unnecessary process - someone just needs to fix whatever line of code on the forum that’s forcing the app to open to apparently the wrong section.

1 Like

I work with a lot of apps. It happens sometimes to the best of them. It really takes about as much time to reply to this forum.

Not solving the problem, but a work around and what I used on my phone.

I assume they have a Play Store version as well.
I have the same problem with Amazon links and the Amazon app. Any link to an amazon website always opens the Amazon app on my phone, but there are certain things you can’t do, or I don’t want to do via the app.

The Discourse App isn’t the greatest, but it works on the go.

I had this same problem (android phone) and corrected it by going to “settings” then “APPS” then “Sense” , “APP info”, then “set as default”, then go to “supported URLs”. I then changed it to “always ask”
I did that for both apps.
That fixed it for me.

EDIT>>> After reading the OP again I realize my issue was different. But I will leave this reply here because it could still help someone with the same login issue I had.

Ignore my previous post. I was thinking of the Discourse app working for me.

I just let our lead web dev know about this and submitted a bug report.

1 Like

I am also now hitting this. I only learned I was hitting it as Discourse released an app update
(v1.4.0) which has completely bricked itself on iOS 12.1 also released today. I figured no biggie I’d log in via Safari… but nope. :slight_smile:

Update on the Discourse Hub update:

I uninstalled/reinstalled Discourse Hub. Adding the Sense community back results in… nothing. The same thing affecting mobile logon must also be affecting the Discourse app. The other Discourse forum I visit and usually have in the app is running an older version of Discourse and the app won’t connect to it, even though it was prior to the app update.

Guess I won’t update to 12.1 yet (but the new emojis! :sob:)

This is on our radar but we have pretty limited web resources and are working on some other web updates (that you’ll probably like a good deal). I’ll update when I know more. It’s a frustrating issue on my end as well, since I prefer to use my mobile devices once I leave the office.

Exactly why I updated! LOL

I don’t know if it’s the Discourse update or the iOS update that hosed it, may want to steer clear of both for now.

1 Like

Thank you, that setting change works for now!

I still can’t access the forums via mobile, unfortunately that solution isn’t an option for iPhone users, so I remain locked out through the day.

Although I did discover today you can reply to the “someone responded to your thread” email alerts and supposedly it translates to the forum…which is what I’m doing now.

Let’s see if it works.

1 Like

If you haven’t updated to 12.1, is the Discourse app working for you?

I am on 12.1 now.

And nothing personal, but I hate (with a passion) apps for forums and websites. And mobile versions of pages as well. Both tend to offer crippled versions of the underlying sites, missing features and options etc.

Maybe I’m a purist, but I like the good old fashioned browser vs every website and forum having countless number of proprietary apps. :slight_smile:

So, yeah, I’m looking forward to being able to logon here on my phone, in my browser.

The Discourse app actually isn’t too bad. In general, I really like them as a company and I was pretty happy when I inherited this forum to find out that it used the Discourse software. I prefer their app to the mobile experience, honestly. But hopefully we can get the latter working again soon!

So I might have stumbled across a kind of ugly workaround, but would need someone else to confirm.

I have Discourse Hub installed which is just a wrapper for browsing multiple forums. I uninstalled it and installed it, then added back. However… after it authorizes the Discourse Hub screen goes entirely blank making the app useless. :man_shrugging: But… if I then launch Safari it seems to have performed the forum login and I’m now able to browse the forum on my phone via Safari.

If I then log out of the forum and try to log back in via Safari directly, it launches the Sense app. :boom:

The video here is what I see when trying to add Sense to Discourse Hub. It would seem they have some issues on their end.

Discourse Hub 1.4.1 was release overnight on iOS and I can once again view the Sense forum without a problem.