All 3 of my HS110 were shown by Sense as being powered off overnight


I awoke this morning to find that according to Sense, all 3 of my HS110 outlets had gone offline as if they had been powered off. According to the logs they went offline at 2:20AM ET and then back on at 9:14AM. None of these devices were shut off and the services connected to them continued to operate as normal.

I used the HS110 in an attempt to separate out my Always On loads for things like Internet Core with router, Drobo;s, etc as well as Home Theater and the 3rd one is on my iMac. The goal as to better understand the loads of those always on services since they’ve just been a 400+W blob of load all the time. Unfortunately Sense saw them all go offline and record no load for 7 hours or so overnight which makes that effort useless.

Also, am I reading other threads correctly that since I chose to put these on Always On load locations I should expect that all of my load is now double recorded from the HS110’s and then again in the Always On bucket?

Hs110 is being shown as off

Take a look at my other thread (“HS110 became disassociated”) and see if it presented the same as my problem did.


It doesn’t seem like I’m having the same issue as described in yours since there was no disassociation, Sense just recorded all 3 of them as being turned off for ~7 hours when they were actually still on and powering the connected devices as normal. All 3 went off at exactly the same time and came back on at exactly the same time. I didn’t do anything to them at all and after about 7 hours they came back online and started recording the same load levels they were recording before. I looked a couple of times during the day and everything was normal, and right now when I’m looking I see the proper results, except for the double-recording on Always On.

To be honest this looks a lot like the issue I had with the Hue Bulbs when that support first started where Sense was showing a bulb going off for a few minutes and then coming back on constantly but the bulb had been on the whole time.


First, if you haven’t already, please submit a ticket to Support about this.

Two questions in the meantime:

  1. How have you set up your smart plugs? Are they set up on individual devices? On power strips? If the latter, are those devices selected from the list of Devices in the What’s Plugged In screen? That should stop any double counting. You can read more about this process here:

  2. What’s the Kasa app showing? Are they showing as On in the periods that Sense is marking them as Off?

  1. All of the Smart Plugs are set up as Power Strips since the device directly connected is a UPS which has a varying number of devices plugged into it depending on which one it is. There are no devices on any of them that had been ‘found’ by Sense and most all of them would be expected to be Always On, which it seems is resulting in double-counting my Always On. Since Sense had never discovered any of that stuff I wanted a little better picture of where the Always On was being spent and as expected, these 3 locations account for pretty near all of it. But now, I see the 3 bubbles for the Plugs and I still see the same Always ON bubble which is, as a result double-recording the load of these devices.

  2. The Kasa App shows nothing happened at all. It says the plugs have been on 100% since they were installed. I disabled the ability to switch them on and off specifically to prevent accidentally doing so as all the devices connected need to Always be on.

Also, when I looked at logs on some of the devices connected like my router and iMac, absolutely nothing lost power during this 7 hour event. Everything was fully operational the whole time, Sense just saw the devices go off line much like it used to (and ocassionally still does) with the Hue Lights when that support first rolled out.


So in frustration with the additional issue of double-counting Always On and Other going away, this morning I disable the HS110 integration and immediately things went back to ‘normal’ with a proper Always On and Other came back again. I guess I’ll just leave it this way and see if a fix shows up or find I ended up wasting the money on these plugs that I only purchased in hopes of better understand my power utilization of Always On devices


Did you end up submitting a report about this to Support?


To be totally transparent, given my history of less than positive or productive experiences with support, I had very low hopes it would matter so I didn’t bother. I have now opened up a case but the integration has been turned off in the Sense app due to the multiple significant bugs I experienced.


I’m sorry about the issues you experienced with Support. We’re a very small team, so it can be a challenge to fully assess complex bugs in a timely manner. Still, I hope you’ll submit issues to Support. That’s how we improve the product.


I installed a hs110 smart plug, sense found it, but it doesn’t report any usage for it and it is always displayed as off. I can see that the plug is on and has usage from the kasa app.


Quick checks:

  • HS110 firmware up-to-date (1.2.5) ? Us the Kasa app to update if needed.
  • TP-Link enabled in Sense app under Connected Devices ?
  • HS110 on the same subnet as Sense ? Kasa app can see beyond subsets in default Remote mode.

May also take a little time to be found by the Sense probe.


And is the Settings->My Home->Network identification setting a factor. Does it have to be enabled for HS110 devices to be found?


I don’t believe that Settings->My Home-> Data Sources->Network Identification has to be enabled. That’s a different kind of identification based on looking at network packets from smart devices, especially TVs. But I do have that enabled as well.


I’m running 1.2.5 firmware on the hs110. Tplink is enabled in sense and is on the same subnet.
The sense detected the plug and added it to my device list, it just doesn’t pick up any usage from the plug. It shows up as off in the sense app and 0w in usage. The kasa app does show real usage though.


I setup a new HS110 as well (to join all my others) and had the exact same issue. Implementation is still buggy it seems.

I unplugged the HS110 and plugged it back in several times…that eventually seemed to resolve the issue and it’s measuring fine now, although I’m finding the Sense app painfully slow today, but that’s another story.


I’ve got three of these plugs and they function great, but for some reason Sense keeps detecting that one of them is randomly turning off and then back on when it is really on the entire time.


I have 8 now and they pretty much all get detected as “Off” regularly even though 4 of them are never off as they are on most of my always on devices (internet router, and the likes). It definitely seems a bit buggy still.


If you’re having issues with Sense not detecting certain HS110s or they occasionally show as Off in Sense but on in the Kasa app, please submit a ticket to Support.


submitted a ticket to support.

@RyanAtSense - is this a well known issue? Is it related to network config at home or something on Sense’s side?


So after doing some testing I came to the conclusion that (at least for my situation) there’s simply a “translation” issue between the Smart Plug functionality and the “Message me when things turn on/off” functionality. I had this turned on to message me when any of my “Always On” Smart Plugs are turned off so I kept getting messages that they were. However, when you dig into it a bit, the Smart Plug didn’t actually go “off”, but it went “idle” as apparently all the equipment on the powerstrip connected to the plug went to “sleep” mode. This does however trigger the “Send me a message when this thing turns off” function.

So I think we’re going to need some fixes @BradAtSense/@HilarioAtSense :

  • For smart plugs a new “Notify me when this goes idle” option should be added so we can get messages when this happens.
  • For smart plugs the “Notify me when this goes off” option should only notify if there really is no more power being drawn because the device(s) is actually off.
  • For smart plugs a new “Notify me when the Smart Plug is switched off” option or something like that should be added that we can get messages for that should only trigger when the actual Smart Plug itself is turned off.