Android app bug in device power meter

To see this bug

  1. Go to devices.
  2. Open a device that is NOT running
  3. Go down to the bottom and open the power meter.
  4. Zoom the graph in if needed.
  5. Scroll the timeline to the left and line the vertical bar on a time period where the device was powered on.
  6. The wattage will show in the top right as you are scrolling the graph, but almost immediately after taking your finger off your phone the wattage will show 0W.

Here’s an example screenshot. It should be showing about 30W but instead shows 0W. I tried several times to get a screenshot that showed the consumption and just couldn’t do it fast enough before the number went back to 0.

If the device IS currently running, instead of resetting back to 0W it will actually show the current W instead of the historical W you have currently highlighted. I am only 85% of this though because I don’t have many detections where the wattage varies to test.

My phone is a Pixel 2 running Android 9 on the latest security update. The Sense app reports that it is version 27.4-70e7a90 build 1066

This doesn’t happen to me. I’m running the same version/build on a Galaxy Note 8

Interesting. I tried on an Android device and couldn’t reproduce, on the same build. I’d suggest writing into Support about it. Something odd may be happening locally.

Actually, after 3 days of having this problem, it seems to have gone away on it’s own. As someone who works in IT, I see this often. Some problems only go away when you decide to tell others about it.

2 Likes

Glad to hear. If you see it again, grab some screenshots and send over to the Support team.