HS300 not being detected

I installed an HS300 a week or two ago and Sense still doesn’t see it.
It shows up in my Kasa app.
It is on the same wifi as my Sense and on the same subnet.
I’ve connected to that subnet and can see both devices.
Network discovery was on and I turned it off after about a week and no change.
I’ve toggled the TP-Link integration and no change.

What else can I try?
What other data can I provide?

Hey @MrCarney. I have a KASA HS-300 as well!
It sounds like you haven’t connected your KASA in the Sense app. To connect your smart plug, go to:
Settings > My Home > Connected Devices > Smart Plugs and enable the TP-Link HS110/HS300 Smart Plug. There’s some more information here re: setting up your smart plug. Let me know if that doesn’t solve the issue!

Thanks for responding Justin. It was enabled first thing after I installed it two weeks ago. I toggled it off and then back on about a week ago or so and still nothing. I’m happy to submit a support ticket if you think that’s what I should do.

I just confirmed that there aren’t any bugs with KASA plug integrations on our end right now, we’re only seeing an issue with Wemo plugs. If you could reach out to Support, they will be able to provide more insight.

Are the Sense and the HS300 attached to the same WiFi access point / base station ? If not, you might have a switch in the middle that blocks the broadcasts and responses that Sense relies on.

3 Likes

They are. Just one access point for me. Thanks for the thought Kevin.

What AP do you have? Router?

There are so many “standards” with meshes and wifi that often things can go sideways through no real fault of the TP-link or Sense connection methods.

I have a Cisco Aironet 1262N which is managed witha Cisco 3850.

Possibly something to do with multicast routing being blocked by your switch:

https://www.cisco.com/en/US/docs/switches/lan/catalyst3850/software/release/3se/consolidated_guide/b_consolidated_3850_3se_cg_chapter_0101000.html

I have a Cisco 1832I acting as a WLC. It blocks the packets and I haven’t worked out how to allow them.
I had to move all of my Sense/TP-link equipment to an old 2.4Ghz WAP. It passes the packets without an issue. I also changed it to 11Mb/s (802.11b) on channel 1. This give the access throughout my whole house and garage without any issues.

Thanks. I had to work through this with my chromecasts and some other media casting. I’ll take a look and see if it didn’t get applied to this WLAN.

In case anyone finds this thread in the future, I did some more digging. I found that Sense was broadcasting UDP packets to 255.255.255.255:9999 in order to get the Kasa plug to send back it’s IP address (this is actually part of the zeroconf stuff that it does when it’s newly configured - the app connects to the plug’s SSID and then sends the same packet to figure out what IP the plug is on).

That’s not multicast, that’s broadcast, which led me to figure out that by default Cisco WLCs drop broadcast packets unless you turn on broadcast forwarding. Thankfully for me I was able to enable it for just that VLAN with the wireless broadcast command on my WLC.

The plugs showed up within minutes!

2 Likes

Congrats… Sorry I didn’t point you to this earlier. I mentioned broadcasts, but didn’t get more specific.

1 Like

Something else may be going with the TP-Link devices. I had 1 that was never detected even though it was attached to the same access point as my other TP-Link devices. I had to unplug it from the wall and plug it back in for it to finally be detected. Not an easy task because it’s behind a 100 lb plasma TV hung on a wall requiring a 6’ ladder to get to it. Oddly, I had several other HS110 devices that were detected but weren’t even plugged in when I turned on TP-Link device detection. The only thing I can guess is that Sense detected them when I first set them up a few weeks ago and they were plugged in for maybe 5 minutes total each.

Once the TP-Link devices are set up in the Kasa app, Sense can spot them, even if they are only online for a short time. The plugs all respond to the broadcast Sense sends out. Occasionally some of mine will disappear, and the fix is to turn off NDI then turn it back on.