No trends data, the rest is fine

3 or 4 days ago my Trends data is showing Monitor Offline. The rest of the app is working great so it makes no sense why it stopped recording the usage.
Sense people is helping me but if anyone already had this issue can share recommendations on what to do?
I have tried login out, re installin app, energy blackouts. The only thing missing is FACTORY RESET, bit I will lose all my data collected this 18 months.
Please help guys

If your Power Meter is showing live waveforms (the power your house is using right now), and it is not zeroed out, then the Sense mothership is getting your data. Things like Trends and Device data are derived/aggregated in the Cloud. But if you Power Meter is not showing the data for right now, then you probably have a network issue. One additional way of checking is to go to Settings > My Home > Sense Monitor to look for this:

Yes…already tried that

I second @kevin1 suspicion of a network issue being the cause here. Did Support tell you to factory reset your monitor? I would recommend holding off on that and seeing what Support directs you towards as a fix here.

I will hate to loose (again) a year of data that I normally use to sell solar products and let me know my house behaviour, so I will leave the factory reset for last option. Hope today someone in sense figure it out.
I will keep you posted the final result on this matter.

are you running pi-hole, or any sort of network level DNS filtering? Wondering if maybe a gravity update has blocked access to the AWS server where historic data is stored?
I don’t know if the network connectivity test pings all of the Sense services, or is just testing for basic internet, but have you tried running that?
On the mobile App - Settings / Home / Sense Monitor then choose Network test at the bottom of the Network Connection section. You will need to near the Sense as it needs a bluetooth link to check in with the Sense.

Yes network test was performed and actually improved by moving the modem a little bit.closer to sense.
Since this is a system operating for couple of years and issue happens after a 2 sec power outage, I believe is not a network or new firmware etc blocking data. But I am not an expert, so let’s see what Sense team has to say about this.