Weird message after enabling time of use settings

I just adjusted (in the web app) the end dates (and the amount for early morning which was off)

Also enabled the “show cost” and still have the same weird error.

If there is something wonky in the web app, is this the place to report it?

Three thoughts…

  1. Report to support@sense.com

  2. The motor different I notice when I look at mine in both the iOS app and the Web App is that my “bells” have turned green. That implies that there is still an error in your Rate Zones, though you have been able to save them. In the app, one can save as long as there is an error.

  1. One hint of potential wonkiness. When I go to edit one of my working Rate Zones in the Web App, I get the error below. That doesn’t show an error per se, but it does show that the code is different. You obviously got around this issue by running your time to 11:59PM. But “datetimes” are notoriously tricky in code because of some of these little idiosyncrasies.

Let me help you out:

The green bells is when you choose to be notified in which zone you are “alert me when entering this zone”
There is a slider at the top where enable/disable that at the top of field where you start defining that.


There is no “error” in my definitions I can assure you

I added the weekend as well: still the same “wonky” error

So indeed I will have to revert to emailing support.
Hoped to have helped you out with your green “bells” :wink:

Thanks for the pointer on “green” vs “gray”… Have your tried to turn on the Zone Alerts ? I ask because my time zone alerts show up exactly where your “black box” is.

I have to turn on alerts to avoid seeing a bug?
Are you kidding me?

I am one of these person who has adblockers on everything, runs pi-hole as DNS.
Life is blinking enough sh* info in my face.
I know perfectly well when what ToU is active.
I do not want to notified, thank you!

1 Like

Probably related

How do i turn off these useless “NEWS UPDATES” on the left column?

Hi @dannyterhaar. The Time of Use feature error you’re experiencing looks like a bug - Support will be able to look at this on our end. Thanks for reporting the issue and sending them an email.

Regarding timeline updates: you can click the “x” in the top right of the notification to remove it from the top of the timeline feed.

But they keep popping up (and taking over the time line) if I don’t click them away.
Is that intended behavior?
Each device you can select “do you want to see it on your time line?” but these useless messages are “always” on?

I thought you were referring to the top two regarding your rate zones, but it sounds like you’re referring to all timeline notifications (devices turning on AND rate zone updates).

There is not currently a way to remove the entire timeline from your ‘Now’ screen view. It looks like you’re on a Tablet (based on your screenshot), where I believe the timeline is a little bit more prominent than the Web app (home.sense.com) and mobile app views of the same screen. I included screenshots from my home of both the Web app and Mobile app for comparison, in case either of these options are more to your liking.

Web


Mobile

check out
https://home.sense.com/settings/notifications

I think this is the page you seek. you can turn off the “energy changes” notifications.

3 Likes

ty, that was what I was looking for

I only mentioned twice I am on the web app.
4K monitor on my desktop

Must have missed that, your timeline looks enlarged compared to my view in the Web app.
It’s probably all those pixels :slight_smile: .

@ben I tried to switch that setting off

I hit “save changes” (nothing happens)

Go back to my “NOW” page

As you can see it has filled up my left top part of the “NEWS” section.
When I go again to those settings page, it is ENABLED again.

Did I run into another “feature” ?
:smiley:

Yep! It looks like you found a bug. I can make the change via the mobile app, but cannot via the web app.
It looks like a Javascript error.
Did you already e-mail support? I would add it to the ticket and hopefully they can take a look at it, but in the mean time, I would put the app on a phone/tablet even if its not your main device to use because the phone and web app are not at parity feature wise, and usually, the app is a bit more bug free.

index.js:139 Uncaught TypeError: e is not a function
    at index.js:139
    at Object.u (react-dom.production.min.js:14)
    at M (react-dom.production.min.js:15)
    at react-dom.production.min.js:15
    at W (react-dom.production.min.js:17)
    at w (react-dom.production.min.js:18)
    at L (react-dom.production.min.js:18)
    at T (react-dom.production.min.js:21)
    at gn (react-dom.production.min.js:84)
    at Nc (react-dom.production.min.js:250)
    at De (react-dom.production.min.js:39)
    at wn (react-dom.production.min.js:86)
    at react-dom.production.min.js:251
    at Object.t.unstable_runWithPriority (scheduler.production.min.js:18)
    at Ec (react-dom.production.min.js:251)
    at En (react-dom.production.min.js:85)
    at HTMLDocument.o (raven.js:376)
2 Likes

Thank you for the feedback

Just to make sure:
I logged out, removed cookies, logged back in to make sure we start “fresh”

I go to the setting page:

Change it to everything off

And looks like it is not saving at that point.
Probably same reason why it won’t let me click away the NaN message.

I did what you suggested, turned off notifications in my android app, problem solved.
Will try and add it to the ticket.

Thanks again

1 Like

Thanks @ben - great catch, actually. This is probably related to a known bug that escaped me with the recent Ecobee integration fix rolling out.

I’d imagine that’s the source of some of the ToU related issues @dannyterhaar is seeing, but can confirm on Monday once I touch base with Support.

followup:

Even after all my notifications → significant energy changes are all disabled (on the android app)

I still see all those (for me useless) notifications:

Is this another bug and/or related to the JS condition?
Hope to find out next week

At this time, I believe the issue is related to the bug I linked in the comment above and will be able to confirm with you on Monday.

@dannyterhaar It looks like one of the issues is related to the existing bug with the Web app being unable to save changes.

Support will continue looking into the ToU issue you’re seeing, so please continue to communicate with them directly through email.

On a separate note, at this time you can’t disable the TOU usage related timeline notifications. All other notifications can be toggled through the Settings as @ben mentioned above.

1 Like