Smart plug issues again

So a couple months ago I was having an issue where half of my smart plugs were showing up as turned off in Sense but when I know that these plugs are turned on and working and show up correctly in their own app as well as correctly in my apple home app and my Alexa app. After almost two months of trying to fix this issue and then getting very slow help from tech support I ended up resetting data in the Sense app and starting over. the first week went well and things seemed to be fixed but last week while I was across the country in California I was checking my app and realized that half of my smart plugs were showing as off again even though I know for a fact that they are on and one of the devices that was showing off was my modem and router which would prevent me from connecting to my Sense monitor. I was told this was an issue on my side and that is was due to a poor network connection when I first contacted tech support so I added a network extender yet here I am again less than a month later and I am having the same issues. I’ve opened another trouble ticket but like the last few times I am not expecting these issues to be resolved anytime soon. So either the device integration has major issues or there is something wrong with my sense device.

Oh and I would like to mention that the issues are with my TP-Link smart plug and smart power strip as well as the WeMo smart plugs.

Hi Mike:

You detail what’s going on well, if I suspected a weak wifi signal as the issue, I’d attacked the problem as you did with two exceptions. The goal is to “divide and conquer”, thus change the most likely variable while holding all others constant. I’m using (6) TP-link KP115’s.

First I would have looked at the smart plug app’s reported wifi signal strength in dBm. I have consistent success with levels of -76dBm or better. Better means less negative, i.e. closer to 0dBm. My best signal is -31dBm from a smart plug that is 8ft away from the wireless router in my office.

Adding an extender adds another unknown, thus I would have moved the problem smart plugs closer to the wireless router or added physical cabling to move the router closer to the smart plugs. This is just temporary for diagnosis of course.

My experience would lead me to think you’re more likely to be having trouble with the router’s address handling (DHCP management). Assuming you have enough addresses allocated for the devices in your network subnet, force the router to renew the DHCP leases. You may have to power cycle each smart plug as well. Verify that each smart plug has a new IP address. If this fixes things, you don’t have a signal strength issue and I would suspect that the fix may be temporary. If the problem crops up again, make adjustments to the DHCP schedule and possibly other DHCP variables I don’t know about. The easiest fix might be a router upgrade through a vendor like Amazon that allows easy returns. This of course could also win you additional signal strength.

A final thought - if you’re having this problem using your smart phone, disable the wifi reception temporarily and use your cell data and see if that helps.

Good luck!

Hi @mike_gessner, you made me go back and take a closer look at my smart plugs, too. Looking this morning I see two issues:

  1. An HS300 that is seen by the Kasa app, but not by Sense. My Sonos boxes, TiVo mini, AppleTV, Hue controller and a Netgear switch are all on this one. I will have to check to make sure this HS300 is connected to the right WiFi network.

  2. An HS110 that is not seen by either Sense or the Kasa app. When I look at that smart plug, it is showing the orange light that means it is off the network, so I will need to put it back on network.

I’m also noticing what seems to be a new phenomenon. Sense is showing an n/a for these devices, as well as the Hue devices I moved to the other WiFi network, rather than an off. I think that is new - I’ll have to look at the export to see if the NA makes it all the way through to the output export.

Will investigate more and report to support if necessary.

ps: For me, the last exported reading from devices on that HS300 were at 23:00:00 on Nov 20th.
pss: Hope you have a good trip to CA. Did you visit NorCal or SoCal ?

I’ve been having these same issues since installing my KP115s and honestly I thought I was alone in it.

@RyanAtSense was looking into it last time i talked to him.

@kevin1 if you haven’t already, please write into Support so we can take a further look into the issue.

Same for anyone else experiencing this issue. My HS-300’s are appearing in the app normally, so I’m unable to reproduce.

1 Like

I submitted a trouble ticket before I posted this and just noticed that I got an email back from support and they say its a bug and they are looking into it further.

I have some HS300’s and (newly) KP115’s. So far no “reporting in” issues.

I will say, though, that I go into my DHCP server and set up static addresses for all my truly-known devices. So the same MAC device value always gets the same IP4 network address. I found in the industrial automation world this can help with reliable network connections and diagnosis - in part, for example, because it reduces potential for conflicting IP addresses if the router/DHCP server restarts. I even try to ‘group’ fixed addresses by device type (e.g. .60-.69 for Wemo plugs, .70-.89 for KS300’s, …) but that’s just for my “ease of recognition”.

Another benefit is that “new” devices are easily seen in that they show up in the ‘dynamic’ DHCP range (which is smaller than the default range, since most of my devices are ‘fixed’ addresses) … and that makes it easier to identify devices which have either ‘no name’ or rather obtuse names which don’t seem to have any association with what the device actually is.

That being said: network signal strength & bandwidth seem to be crucial. Remember that smart plugs are polled by Sense frequently.

The other factor I’ve recently uncovered is having IOT (Internet of Things) devices which support both 2.4 & 5Ghz WiFi. Specific example: I have a Ring doorbell which supports both, but the location is such that the 5G band is iffy at that location, but the 2.4 is great. So what I did is create a 2.4-only “guest” network (with password and with Internet), and re-connected the Ring to that 2.4 “guest” network. The Ring device is now far more responsive than it ever was before.

4 Likes

FYI: The main problem with putting Ring on ‘guest’ network is that then I couldn’t see the Ring when outside the home … that could be solved by using a bridge between the subnets, but I decided to solve it by adding an additional access point (since I now have wifi-6 mesh network), very close to the Ring device (e.g.: in the basement just under the front door), and putting the Ring back on the main network.

Additional note:
When I added a 4th HS300, two of the previously existing 3 HS300’s “went away” … for a while. But then they came back later within Sense (took a day or two).

Now just need Kasa to work with HomeKit. I’m using the KP115’s where I don’t currently need to ‘control’ the device with automation, but where I do want the device to come back after a power failure in the same state it was before (e.g. freezer). I’m considering a couple of places where I might have to “double up” (e.g.: put in KP115 to measure power, then an iDevice plug to be able to HomeKit-control the device). Might have to rig up a support so the weight doesn’t pull the combination out of the socket, too.

1 Like