What's new in Web App v10: Trends

We’ve just released a new iterative update to the Sense Web App. v10 now includes improved Trends graphs and adds billing cycle support to the Trends screen.

Changes include:

  • The addition of Billing Cycle to graphs on the Trends screen and all device-based Trends graphs
  • Backend updates that should speed up initial load of all Trends graphs
  • Graphical updates to all Trends graphs
  • Additional bug fixes

In general, it’s good practice to log out and clear relevant cache before checking out new Web App updates.

As always, let us know what you think in the comments.

2 Likes

Something definitely wrong. Using Chrome. The graph is tiny.

Can I report other web app bugs here or should I start a new thread?

Try logging out and back in again. Always a good idea for a new web release.

The best place to report bugs is directly to the Support team, but be sure to check the Known Issues forum here first. https://sense.com/contact.

I had already tried logging out and back in. I posted to hastily though. I work in IT, so I usually do my due diligence testing before reporting a bug. It worked in FF and it worked in a Chrome incognito window, so (and this is a useful general web tip for everyone) I refreshed the page by holding ctrl and hitting F5. This forces the browser to fetch the entire contents of the page and not using anything from the cache and this resolved the issue. So it was definitely a caching issue.

Though… to me, on the day view the bar graphs are a little ambiguous as to what time they are actually reporting. If a bar is directly above 10am, is that the time from 9 - 10 or 10 - 11? I’d personally like to see tick marks for every hour (even if only every 2 hours is labeled like currently) with the bars appearing between the lines so it’s clear what time period it’s for. Right now, I have bars over 10am, but it’s almost noon. So I am assuming these bars are for the 10am - 11am period.

Just added a note to the release about this. In general, it’s a good idea to do for web app updates.

I’ll pass along the feedback about the hourly breakdown. Since it’s start at 12AM, it seems intuitive to me that a bar would be for the hour ahead, i.e., 12-1, 1-2, … Curious to hear from others on this, as it didn’t come up in internal or external beta.

Well, I would think so to. I think the reason it doesn’t seem obvious to me, is if you have solar, the green usage bar actually appears to the left of the tick mark for the time while the solar will appear to the right. It’s centered on the blank space between the two bars. It’s just a small nitpick.

Ever since this update, the trends section doesn’t update for me at all unless I log out and log back in. I noticed this morning that the daily trend only went back to about the time I made my last post, so I cleared cache and reloaded. No change. I logged out, and logged back in. All my data is there now. That was around 8:30 this morning.

When I go now and look at trends, no data newer than that has populated. Clear cache, refresh, no change.

The Android app is still working fine, it’s only the web app I’m seeing this in.

I’m seeing the same phenomenon on the web app. The two screenshots below taken 30 secs apart at about 5:22PM.

Originally logged in at about 4:30. Even after refresh or close browser and reopen, trend bar stays frozen at 3PM-4PM interval.

Logout and log back in in between… Suddenly 4-5PM interval is visible.

I’ll take a look and pass along to the web team. Thanks for reporting!

If anyone is seeing the above-reported issue, it’d great if you could log a ticket with the Support team.

1 Like

We don’t have any data on our trends tab since this past tuesday. But the meter and everything else are running fine. Is this a known issue?

Is that in the web app or the iOS/Android app ?

Tuesday is when they updated the web app. If you look in the thread announcing that update, we’ve started discussing this issue a bit. I’m seeing the same thing.

Try logging out and then back in. Does it refresh the data up to the current time?

Also, logging out and back in corrected the issue. Thank you.

1 Like

This is on the web app

1 Like

Thanks for info. I’ve passed along to the team. [Merging this into the v10 thread since it seems related]

Seeing this on my webapp this morning. Support ticket filed.

1 Like