iOS UI Bugs

#1

I know this is the “wish list” section, but there does not seem to be anything for bug reports.

I’ve had many frustrations with the sense product, two specific bugs I’ve noticed in iOS.

There seems to be some kind of caching delay/bug when editing device names. Several times I’ve received the “New device” notification, I go into device settings, rename it, return to the device listing and it’s the old name. Tapping the gear to go into device settings a second time shows the new name. Seems it updates and all is better after the device turns off and on again.

I know it’s a minor thing, but every time I edit a device name my brain locks up and I can’t figure out how to save. The ‘Update’ button in the UITabBar is a very light shade of grey, typically used for disabled controls. I see it, then start scanning the form to figure out which required item I’ve left blank. I’m surprised Apple approved this, their UI/UX guidelines are quite strict. Screenshot below.

These are both on an iPhone 7 running iOS 12.1.4 running Sense build 1359.

1 Like
#2

#1 is a known bug:

#3

Little disappointing that know bugs are going 3+ weeks without being fixed.

#4

Yes, the first is a known bug. We pushed out some fixes to it in the latest app update, but it sounds like you have that. It should no longer be happening and, from what we’ve seen, isn’t.

The second is new. I’m not seeing the same behavior in my app. When the name is changed, the light gray “Update” should be turning to a darker shade of gray. You’re not seeing that? That’s certainly odd.

For both, can you submit a ticket to the Support team about it so they can investigate further?

Support@sense.com

For future reference, all bug reports should be sent to Support. I recommend reading: